Pacman 5.2 breaks dependency required by yay

installing pacman (5.2.1) breaks dependency 'pacman<=5.1.3' required by yay

Récemment lorsque j'ai tenté de mettre à jour ArchLinux avec yay je me suis retrouvé bloqué sur des dépendances cassées avec pacman :

$ yay
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing pacman (5.2.1-1) breaks dependency 'pacman<=5.1.3' required by yay

Donc impossible de mettre à jour pacman en 5.2 parce que yay est dépendant de la version 5.1. Une solution rapide pour résoudre ce problème de dépendance entre ces deux gestionnaires de paquets, yay et pacman, est de supprimer yay, de mettre à jour son système avec pacman et réinstaller yay.

$ sudo pacman -R yay
$ sudo pacman -Syu

$ git clone https://aur.archlinux.org/yay.git && cd yay
$ makepkg -si
$ cd .. && rm -rf yay

yay fonctionne de nouveau :

$ yay
:: Synchronizing package databases...
 core is up to date                                                            135,6 KiB  2,50 MiB/s 00:00 [----------------------------------------------------------------]
 extra is up to date                                                          1645,9 KiB  2,79 MiB/s 00:01 [----------------------------------------------------------------]
 community is up to date                                                         4,7 MiB  2,46 MiB/s 00:02 [----------------------------------------------------------------]
 multilib is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
Packages (183) […]

Commentaires